[Symfony] Problem z symfony i app.php
Radosław Szmytkowski
6/10/2015 | 8:29 PM

Witam Widziałem kurs symfony2 Techniki pracy. Stworzyłem przykładowy Bundle i pod linkiem app_dev.php działa poprawnie Ale niestety pod linkiem app.php nie mam strony tylko 404 a pod domena czyli domena.dev mam listing plików z katalogu projektu. Nie jest to problem z AppKernel.php a raczej wina jest z apachem. Mam ubuntu 14.4 i symfon2.7, apacha i php jest instalowane przez apt-get Jaki może być

Maciek Zukiewicz
6/12/2015 | 7:09 PM

Witam ponownie, jeżeli listują się pliki zamiast uruchomienia aplikacji to na 99.9% jest to wina apache. Proszę sprawdzić czy na pewno dobrze jest skonfigurowany vhost (http://goo.gl/NZGx5 lub w kursie Techniki Pracy lekcja "Konfiguracja vhost") oraz czy w apache włączony jest moduł rewrite (ubuntu: sudo a2enmod rewrite). Pozdrawiam, Maciek

Maciek Zukiewicz
6/13/2015 | 11:06 AM

Witam ponownie, ciesze się, że pomogłem :) Miłego programowania! Pozdrawiam, Maciek

Radosław Szmytkowski
6/13/2015 | 10:39 AM

Witam Faktycznie złe zinterpretowałem reguły dla apache 2.4.* dziękuje i pozdrawiam.

Radosław Szmytkowski
6/11/2015 | 5:16 PM

faktycznie za każdym razem dawałem php app/console ceche:clear a zapomniałem o --env=prod ale pozostaje problem tego iż nie mam nic po wywołaniu domeny tz. domena.local (mam listing plików). w pliku app/config/routing.yml nic nie dodawałem z automatu stworzyła się tam reguła dla wszystkich kontrolerów tego bandl. A można wyłączyć ceche dla routingu ? (app_dev.php) cechuje mi twig ale wyłączyłem.

Maciek Zukiewicz
6/11/2015 | 4:19 PM

Witam, Panie Radku, czy wyczyścił Pan cache aplikacji i podlinkował Bundle w pliku app/config/routing.yml?