[Kurs Symfony2] logowanie użytkownika
Damian Czechowski
11/5/2015 | 8:14 PM

Zrobiłem logowanie zgodnie z kursem "kurs-symfony-zaawansowany" . Niestety nie działa. WebProfiler pokazuje mi komunikat na pasku "You are not authenticated". A po kliknięciu go otwiera się Profiler z zakładką Security i wpisem "No token". W logach znalazłem taką informację: Username "" was reloaded from user provider. [] [] W załączniku umieściłem mój plik security.yml .

Załącznik: security.yml
Maciek Zukiewicz
11/9/2015 | 9:57 AM

Witam, Panie Damianie, już jest wszystko jasne. W encji Common\UserBundle\Entity\User, w metodzie getUsername() zapomniał Pan dodać słowa kluczowego return (linia 113), przez co username dla użytkownika nie został zwracany i nie mógł być wyświetlony. Przetestowałem to na Pana aplikacji u siebie i wszystko śmiga. Pozdrawiam serdecznie, Maciek

Damian Czechowski
11/9/2015 | 6:09 PM

Działa ... dziękuję za pomoc ... pozdrawiam

Damian Czechowski
11/9/2015 | 10:20 AM

ok dziękuję, sprawdzę to wieczorem jak będę w domu .. super pozdrawiam

Damian Czechowski
11/6/2015 | 6:10 PM

Tak, wyczyściłem cache oraz cookies. Podczas logowania po podaniu login/hasło nie pojawiają się żadne błędy. W załączniku przesyłam całą aplikację.

Załączony plik: typerka.zip
Maciek Zukiewicz
11/6/2015 | 3:29 PM

Witam, czy wyczyścił Pan cache aplikacji? Proszę powiedzieć, czy podczas logowania, po podaniu loginu i hasła nie pojawiają się żadne błędy? Proszę spróbować jeszcze wyczyścić cookies w przeglądarce i spróbować zalogować się ponownie. Plik security.yml wygląda w porządku.