[Angular2] Problem
Szymon Zajda
3/8/2017 | 12:44 PM

Mam problem podczas instalacji Angular2. Podczas instalacji/konfiguracji po wpisaniu komendy "npm run start" w "Visual Studio Code" wyskakuje "webpack : Failed to compile" zrzut ekranu z błędami dodałem w załączniku ze względu na ograniczoną ilość znaków. Wszystko robiłem 2 razy równocześnie z instruktorem kursu. Zna ktoś ten problem ?

Załącznik: problem.png
Grzegorz Róg
5/3/2017 | 2:10 PM

Sajmon pliki są zaktualizowane - mam nadzieję, że już działa.

Szymon Zajda
3/12/2017 | 10:52 AM

Czy zostały już wrzucone poprawione pliki źródłowe ? Bo wciągu dalszym mi to nie działa :/

Szymon Zajda
3/9/2017 | 7:12 AM

No niestety po zmianie wersji TypeScript problem jest raczej większy :/ Zdjęcie w załączniku

Załączony plik: problem3.png
Szymon Zajda
3/9/2017 | 6:41 AM

Nie no nie mam pretensji o to że jakiś błąd wystąpił :) To oczywiste że takie coś może się przydarzyć nawet jednej osobie na 1000 :) Więc sprawdzę to co zostało napisane poniżej i zobaczymy :)

Uzytkownik Anonimowy
3/9/2017 | 6:39 AM

Warto tez w package.json podmienić bootstrap na wersje 4.0.0-alpha.6. Mogą wystąpić tego typu problemy z angular cli i bootstrap, bo nie sa one w ostateczynch wersjach. Sam kurs jest kompatybilny z aktualnym angular 2.4.0 i powinien byc w pełni zgodny z angular 4, wiec nie ma na co czekać. Można uczyć się juz teraz, a w kwietniu wydamy drugą część w której zobaczycie co ponad to pojawi sie w ng4

Uzytkownik Anonimowy
3/9/2017 | 6:35 AM

To nie jest tyle problem z angular, co z wersja jasmine. U niektórych osób instaluja sie niekompatybilne wersje typescript i jasmine. Stąd błąd. Trudno było przewidzieć ze taki błąd może się pojawić podczas nagrywania kusru. Sprawdź wersję typescript: tsc --version I zainstaluj w projekcie wersje 2.0: npm install --save typescript@2.0.0 Myślę ze w tym tygodniu wrzucimy poprawione pliki źródłowe

Szymon Zajda
3/8/2017 | 4:46 PM

Podczas kolejnych prób zainstalowania angulara napotkałem kolejny problem ... Zna ktoś rozwiązanie na to ? Próbowałem nawet instalować różne wersje node.js nic nie pomogło. Przeprowadzałem cały zabieg od początku do końca jeszcze raz wraz z rozpakowaniem plików i instalacją na nowo potrzebnych do tego ponownie uruchomiałem laptopa...

Załączony plik: problem2.png